[ロ]EC-CUBE 2.11.4 の管理画面で「※ PHP 拡張モジュール「zip」が無効です。」と表示される

このエントリーをはてなブックマークに追加
はてなブックマーク - [ロ]EC-CUBE 2.11.4 の管理画面で「※ PHP 拡張モジュール「zip」が無効です。」と表示される
Share on Facebook
Bookmark this on Yahoo Bookmark
Bookmark this on Livedoor Clip
Share on FriendFeed
[`tweetmeme` not found]

EC-CUBE 2.11.4 の管理画面にログインして基本情報管理>郵便番号DB登録 の 郵便番号CSV更新
をしようとすると「ご利用頂けません。※ PHP 拡張モジュール「zip」が無効です。」と表示されてしまう。
OSのバージョンは CentOS 5.8(ただし、CentOS5.1あたりからインストールしたやつ)

yum で php-pecl-zip のインストールを試みる。

$ sudo yum install php-pecl-zip
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* base: rsync.atworks.co.jp
* extras: rsync.atworks.co.jp
* updates: rsync.atworks.co.jp
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package php53-common.i386 0:5.3.3-5.el5 set to be updated
--> Processing Conflict: php53-common conflicts php-common
--> Finished Dependency Resolution
php53-common-5.3.3-5.el5.i386 from base has depsolving problems
--> php53-common conflicts with php-common
Error: php53-common conflicts with php-common
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

そうか、途中からphp5.3系にアップデートされているけど、このサーバまだPHP5.1、、、
PHP5.3 に上げたい所だがお客さんサーバなので今は無理。
pecl コマンドでインストールする!


$ pecl install zip
pecl/zip requires PEAR Installer (version >= 1.7.0), installed version is 1.4.9
No valid packages found
install failed

ハイハイ依存関係面倒くさい。。。

pecl 1.4.9 にインストールできる pecl-zipのバージョンを調べる!
酔いどれプログラマーお仕事の愚痴: PHP zip.so の先人の知恵を使う。

$ sudo pecl install zip-1.8.10.tgz

はいった!

php.ini に zip.so を使うように設定

$ sudo vim /etc/php.ini
extension=zip.so

動いた!

Popular Posts:

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

*